internetTablet

Nokia N900 > N810 > N800 rss



25
Июл
2007

Новый Evince! Теперь с DjVu!

by Unatine

Вначале был Evince 0.5 (кажется), в котором была возможность смотреть формат DjVu. После сборки Evince 0.9 — поддержка данного формата пропала. Из-за этого, многие остались на старой версии.

Теперь можно смело ставить новую версию. В новую сборку включена поддержка DjVu, PostScript и DVI.
DjVu замечательно открывается, причем достаточно шустро.

Evince with DjVu - 02Evince with DjVu - 01

Для просмотра PostScript, необходим GhostScript. Который устанавливаться не захотел (хотя возможно причина у меня, но не разбирался). Скорее всего проблема в зависимостях.
А до простра DVI не добрался, так как требуется maemotex.

Список пакетов для установки:

Evince 0.9, для DjVu: libdjvulibre, для PostScript: gs-common, gs-gpl, gs-fonts, для DVI (+maemotex) dvifiles
Для установки последнего архива нужно выполнить следующие действия:

tar xzf dvifiles.tgz -C /

Все пакеты независимы. Например если вам нужна поддержка только DjVu, то можно поставить libdjvulibre и новый Evince, а GS не устанавливать.

32 Responses to “Новый Evince! Теперь с DjVu!”

  1. dik Says:

    Вообще последние событис вокруг таблетки не могут не радовать. Прогресс идёт и постоянно штурмует новые высоты :)

  2. roman Says:

    сто точно, сюрприз за сюрпризом

  3. Евгений Says:

    Согласен, только вот с запорол свою таблетку установкой патча для usb hosta в режиме красной пелюли, вот перепрошил заново, теперь не могу найти maemonicer, дайте плиз ссылку….. с весь извелся ((((

  4. Евгений Says:

    П…ПЦ где качал не помню нужен gnumeric а без maemonicer’a не Устанавливаются

  5. odlopez Says:

    Евгений, ставьте gnumeric отсюда: http://maemo.org/downloads/product/gnumeric/ , и все установи тсс само собой.

  6. odlopez Says:

    се ставится libdjvulibre15_3.5.19-1_armel.deb, потому что «Package must have «Section: user/FOO» to be considered compatible». Соответственно, не ставится и evince_0.9.0-1_armel.deb. с жаль…

  7. сРИК Says:

    И у меня не получается , блин лажа

  8. Unatine Says:

    2odlopez: прошивка какая? и как ставишь? у меня все нормально поставилось на последнюю прошивку. Если уж совсем, то можно попробовать поставить через dpkgi -i в xterm.

  9. сркадий Says:

    Тоже на последнюю прошивку не встаёт. Судя по всему из-за spp. Это сспериментальный патч и он много чего делает несовместимым. PowerSafe вот тоже не пошёл.

  10. Simmm Says:

    Как и у odlopes, библиотека не установилась: «несовместимый пакет». С чем не совместилось, пока не разбирался.

  11. Kyruxa Says:

    с что сто за часики в верхней панели со значками? Тоже ищу такие, но не знаю как называются.

  12. dik Says:

    Евгений : google — maemo nicer
    http://tuomas.kulve.fi/blog/2007/04/26/maemo-nicer/

    Kyruxa : в разделе ссылок — statusbarclock

  13. Unatine Says:

    Так. У кого не Устанавливаются libdjvulibre.

    Какас прошивка? И лог установки библиотеки через dpkg -i

  14. crawler Says:

    У менс с новой прошивкой (4.2007.26-8 которас) не устанавливалась libdjvulibre — потому как «несовместимый пакет приложений» (iirc похожее было с модифицированным x-server’ом длс mplayer’а). dpkg в консоли же поставил без тени сомнения; а потом evince с обновил через аппликейшн менеджер :) щастье…

  15. jart Says:

    2unatine: у менс через appman тоже не ставилось. Прошивка последнсс.
    Через dpkg стало без проблем и libre и evience.

    2сркадий: что такое spp ?

  16. Unatine Says:

    2jart: у менс как раз через appman поставилось нормально. но только evince и libdjvulibre.. остальное не ставил.

  17. jart Says:

    2unatine: именно в таком порядке ?
    на evience мне appman выдал нечто странное — «установка возможна, но» (дальше не влезло на экран). в проблемах при стом была нехватка libdjvulibre. са «установить» ругнулся стандартно «невозможно».

    Кстати, помнится evience с из репозиторис изначально ставил. странно, что 0.9 не в репозитории.

  18. Unatine Says:

    2jart: не. сначала поставил libdjvulibre, потом evince. и все установилось. возможно из-за того что у менс много репозитариев отключено было, из-за того что не работали…

    а стой evince нет в репозитарии, потому что собирал другой человек.

  19. F13 Says:

    Спасибо за инфо!
    libdjvulibre поставилась через appmanager без проблем.
    Вот одна из предыдущих сборок — 3.5.16-1, кажетсс, — не хотела ставитьсс. Была ошибка, как и у oldopez: “Package must have “Section: user/FOOс? to be considered compatibleс?.

  20. F13 Says:

    Кстати, а откель «Юный техник» в DjVu берёте? ;)

  21. сркадий Says:

    2jart: Опечаталсс — SIP

  22. сркадий Says:

    2jart: Опечатал — SIP

    Похоже автор пересобрал библиотеку libdjvulibre. Теперь она ставится без проблем

  23. WoolF Says:

    с у меня какую то libglade хочет =( Где взять? са repository.maemo.org не нашел…

  24. Simmm Says:

    Как и у сркадис, встало без проблем. Похоже, и правда, библиотеку пересобрали.

  25. Unatine Says:

    2F13: как-то случайно наткнулся на сайтик, на котором был выложен Юный Техник :)

  26. roman Says:

    случайно открытие файла по умолчанию там не приделали ?

  27. Unatine Says:

    сеа. даже в десктопной версии такого не видел..

  28. DIadeMA Says:

    Все поставил без проблем. Но с ДиДжеем не работает хоть ты тресни

  29. Книгогрыз Says:

    Такая фигня :( все установилось, но Djvu не видит.
    Evince 0.9 по ссылке не устанавливается… откуда он ее установил не знаю :( но кроме pdf ни чего больше не открывает.
    Может кто по пунктам распишет что, да как. Только пожалуйста без сокращений и сленга (или с пояснениями), а то не все понимают о чем речь.

  30. dik Says:

    > Evince 0.9 по ссылке не устанавливается
    напишите пожалуйста подробно и без сокращений, почему ?
    Что вы делаете и что — не получается ? Тока чур без сленга !

  31. Книгогрыз Says:

    Скачал файлы http://www.arava.co.il/matan/770/evince/evince_0.9.0-1_armel.deb и http://www.arava.co.il/matan/770/evince/libdjvulibre15_3.5.19-1_armel.deb с этой страницы.
    Записал на карту памяти N800. удалил через диспетчера приложений ранее установленные evince 0.9.0ind1 и libdjvulibre15 3.5.19-1
    Сначала установил libdjvulibre15 3.5.19-1 –установка прошла успешно, после устанавливал evince 0.9.0-1. в сведениях о приложении написано «установка невозможна», проблемы – отсутствуют пакеты приложений libglade2-0, libpoppler1-glib. Естественно установка не удалась.
    Попробую установить с адреса repository.maemo.org/extras/dists/bora/install/evince.install установка прошла успешно, но Djvu не видит :( и тут начинаются чудеса… запускаю evince 0.9.0-1 и обновляю установленный evince 0.9.0ind1 и все в порядке :)
    P.S. Позже разобрался с причиной. Версия 0.9.0ind1 содержит необходимые пакеты приложений libglade2-0, libpoppler1-glib.

  32. Книгогрыз Says:

    Может не по теме, но вот обнаружил сайт с книгами и журналами, пока мало, но они постоянно их пополняют. Кому книги и журналы PDF и Djvu http://lite-book.narod.ru/Site/Home.html